Skip to content
GitLab
Explore
Projects
Groups
Topics
Snippets
Projects
Groups
Topics
Snippets
/
Help
Help
Support
Community forum
Keyboard shortcuts
?
Submit feedback
Register
Sign in
Toggle navigation
Menu
upstream
rpms
cmake
Commits
3c1e12e0
Commit
3c1e12e0
authored
2 years ago
by
CentOS Sources
Browse files
Options
Download
Patches
Plain Diff
import cmake-3.20.2-5.el8
parent
3448887f
c8s
imports/c8s/cmake-3.20.2-5.el8
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/0001-Tests-Explicitly-allow-usage-of-git-file-based-proto.patch
+41
-0
...ests-Explicitly-allow-usage-of-git-file-based-proto.patch
SPECS/cmake.spec
+7
-1
SPECS/cmake.spec
with
48 additions
and
1 deletion
+48
-1
SOURCES/0001-Tests-Explicitly-allow-usage-of-git-file-based-proto.patch
0 → 100644
+
41
−
0
View file @
3c1e12e0
From f72734ff7712d6aae837f940a45d6e7508bb182c Mon Sep 17 00:00:00 2001
From: Brad King <brad.king@kitware.com>
Date: Thu, 20 Oct 2022 13:38:20 -0400
Subject: [PATCH] Tests: Explicitly allow usage of git file-based protocol in
test cases
Due to CVE-2022-39253, Git 2.30.6 sets `protocol.file.allow=user` by
default. The change has also been backported to other Git versions by
distros. This breaks some of our test cases that use the file-based
protocol locally to simulate real workflows without requiring network
access. In these cases the file protocol is safe, so explicitly enable
it in the tests.
(cherry picked from commit 79ce0f434e916684d734e136b92e14f472a9d14a)
---
Tests/CMakeLists.txt | 2 ++
1 file changed, 2 insertions(+)
diff --git a/Tests/CMakeLists.txt b/Tests/CMakeLists.txt
index 8e7c04fbd0..d011020f99 100644
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
@@ -1540,6 +1540,7 @@
if(BUILD_TESTING)
)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/ExternalProject")
set_tests_properties(ExternalProject PROPERTIES
+ ENVIRONMENT GIT_ALLOW_PROTOCOL=file
RUN_SERIAL 1
TIMEOUT ${CMAKE_LONG_TEST_TIMEOUT})
@@ -2653,6 +2654,7 @@
if(BUILD_TESTING)
-P "${CMake_BINARY_DIR}/Tests/CTestUpdateGIT.cmake"
)
list(APPEND TEST_BUILD_DIRS "${CMake_BINARY_DIR}/Tests/${CTestUpdateGIT_DIR}")
+ set_property(TEST CTest.UpdateGIT PROPERTY ENVIRONMENT GIT_ALLOW_PROTOCOL=file)
endif()
# Test CTest Update with HG
--
2.31.1
This diff is collapsed.
Click to expand it.
SPECS/cmake.spec
+
7
−
1
View file @
3c1e12e0
...
...
@@ -65,7 +65,7 @@
%{?rcsuf:%global versuf -%{rcsuf}}
# For handling bump release by rpmdev-bumpspec and mass rebuild
%global baserelease
4
%global baserelease
5
# Uncomment if building for EPEL
#global name_suffix %%{major_version}
...
...
@@ -110,6 +110,9 @@ Patch102: %{name}-mingw-dl.patch
# so limit it to some reasonable number (4)
Patch103: cmake-3.20-CPACK_THREADS.patch
# rhbz#2162696
Patch105: 0001-Tests-Explicitly-allow-usage-of-git-file-based-proto.patch
# Patch for renaming on EPEL
%if 0%{?name_suffix:1}
Patch1: %{name}-rename.patch
...
...
@@ -529,6 +532,9 @@ popd
%changelog
* Tue Jan 31 2023 Tom Stellard <tstellar@redhat.com> - 3.20.2-5
- Fix test case broken by git fix for CVE-2022-39253
* Fri Jul 09 2021 sguelton@redhat.com - 3.20.2-4
- Fix update (rhbz#1964407)
...
...
This diff is collapsed.
Click to expand it.
Write
Preview
Supports
Markdown
0%
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment
Menu
Explore
Projects
Groups
Topics
Snippets