Skip to content
GitLab
Explore
Projects
Groups
Topics
Snippets
Projects
Groups
Topics
Snippets
/
Help
Help
Support
Community forum
Keyboard shortcuts
?
Submit feedback
Register
Sign in
Toggle navigation
Menu
upstream
rpms
firefox
Commits
64f13b1f
Commit
64f13b1f
authored
4 years ago
by
Carl George
Browse files
Options
Download
Patches
Plain Diff
CentOS debranding
parent
b41e6b9e
c8s
imports/c8s/firefox-91.2.0-1.el8_4
imports/c8s/firefox-78.13.0-2.el8_4
imports/c8s/firefox-78.12.0-1.el8_4
imports/c8s/firefox-78.7.1-1.el8_3
imports/c8s/firefox-78.6.0-1.el8_3
No related merge requests found
Changes
4
Hide whitespace changes
Inline
Side-by-side
Showing
4 changed files
SOURCES/Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
+12
-0
.../Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
SOURCES/Bug-1526653---fix_user_vfp_armv7.patch
+35
-0
SOURCES/Bug-1526653---fix_user_vfp_armv7.patch
SOURCES/firefox-centos-default-prefs.js
+35
-0
SOURCES/firefox-centos-default-prefs.js
SPECS/firefox.spec
+17
-0
SPECS/firefox.spec
with
99 additions
and
0 deletions
+99
-0
SOURCES/Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
0 → 100644
+
12
−
0
View file @
64f13b1f
diff -up firefox-60.0/mfbt/LinuxSignal.h.mozilla-1238661 firefox-60.0/mfbt/LinuxSignal.h
--- firefox-60.0/mfbt/LinuxSignal.h.mozilla-1238661 2018-04-27 08:55:38.848241768 +0200
+++ firefox-60.0/mfbt/LinuxSignal.h 2018-04-27 09:06:47.946769859 +0200
@@ -22,7 +22,7 @@
__attribute__((naked)) void SignalTrampo
void* aContext) {
asm volatile("nop; nop; nop; nop" : : : "memory");
- asm volatile("b %0" : : "X"(H) : "memory");
+ asm volatile("bx %0" : : "r"(H), "l"(aSignal), "l"(aInfo), "l"(aContext) : "memory");
}
# define MOZ_SIGNAL_TRAMPOLINE(h) (mozilla::SignalTrampoline<h>)
This diff is collapsed.
Click to expand it.
SOURCES/Bug-1526653---fix_user_vfp_armv7.patch
0 → 100644
+
35
−
0
View file @
64f13b1f
From fd6847c9416f9eebde636e21d794d25d1be8791d Mon Sep 17 00:00:00 2001
From: Mike Hommey <mh@glandium.org>
Date: Sat, 1 Jun 2019 09:06:01 +0900
Subject: [PATCH] Bug 1526653 - Include struct definitions for user_vfp and
user_vfp_exc.
---
js/src/wasm/WasmSignalHandlers.cpp | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
diff --git a/js/src/wasm/WasmSignalHandlers.cpp b/js/src/wasm/WasmSignalHandlers.cpp
index 636537f8478..383c380f04c 100644
--- a/js/src/wasm/WasmSignalHandlers.cpp
+++ b/js/src/wasm/WasmSignalHandlers.cpp
@@ -248,7 +248,16 @@
using mozilla::DebugOnly;
#endif
#ifdef WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
-# include <sys/user.h>
+struct user_vfp {
+ unsigned long long fpregs[32];
+ unsigned long fpscr;
+};
+
+struct user_vfp_exc {
+ unsigned long fpexc;
+ unsigned long fpinst;
+ unsigned long fpinst2;
+};
#endif
#if defined(ANDROID)
--
2.20.1
This diff is collapsed.
Click to expand it.
SOURCES/firefox-centos-default-prefs.js
0 → 100644
+
35
−
0
View file @
64f13b1f
pref
(
"
app.update.auto
"
,
false
);
pref
(
"
app.update.enabled
"
,
false
);
pref
(
"
app.update.autoInstallEnabled
"
,
false
);
pref
(
"
general.smoothScroll
"
,
true
);
pref
(
"
intl.locale.matchOS
"
,
true
);
pref
(
"
toolkit.storage.synchronous
"
,
0
);
pref
(
"
toolkit.networkmanager.disable
"
,
false
);
pref
(
"
offline.autoDetect
"
,
true
);
pref
(
"
browser.backspace_action
"
,
2
);
pref
(
"
browser.display.use_system_colors
"
,
true
);
pref
(
"
browser.download.folderList
"
,
1
);
pref
(
"
browser.link.open_external
"
,
3
);
pref
(
"
browser.shell.checkDefaultBrowser
"
,
false
);
pref
(
"
network.manage-offline-status
"
,
true
);
pref
(
"
extensions.shownSelectionUI
"
,
true
);
pref
(
"
ui.SpellCheckerUnderlineStyle
"
,
1
);
pref
(
"
startup.homepage_override_url
"
,
"
http://www.centos.org
"
);
pref
(
"
startup.homepage_welcome_url
"
,
"
http://www.centos.org
"
);
pref
(
"
browser.startup.homepage
"
,
"
data:text/plain,browser.startup.homepage=file:///usr/share/doc/HTML/index.html
"
);
pref
(
"
geo.wifi.uri
"
,
"
https://location.services.mozilla.com/v1/geolocate?key=%MOZILLA_API_KEY%
"
);
pref
(
"
media.gmp-gmpopenh264.provider.enabled
"
,
false
);
pref
(
"
media.gmp-gmpopenh264.autoupdate
"
,
false
);
pref
(
"
media.gmp-gmpopenh264.enabled
"
,
false
);
pref
(
"
media.gmp-gmpopenh264.enabled
"
,
false
);
pref
(
"
plugins.notifyMissingFlash
"
,
false
);
/* See https://bugzilla.redhat.com/show_bug.cgi?id=1226489 */
pref
(
"
browser.display.use_system_colors
"
,
false
);
pref
(
"
layers.use-image-offscreen-surfaces
"
,
false
);
/* Allow sending credetials to all https:// sites */
pref
(
"
network.negotiate-auth.trusted-uris
"
,
"
https://
"
);
pref
(
"
security.use_sqldb
"
,
false
);
/* Use OS settings for UI language */
pref
(
"
intl.locale.requested
"
,
""
);
/* See https://bugzilla.redhat.com/show_bug.cgi?id=1672424 */
pref
(
"
storage.nfs_filesystem
"
,
true
);
This diff is collapsed.
Click to expand it.
SPECS/firefox.spec
+
17
−
0
View file @
64f13b1f
# Set for local builds only
%global disable_toolsets 0
%ifarch %{arm}
%if %{defined el8}
%undefine _debugsource_packages
%endif
%endif
%ifarch i686
# no debug package for the i686 because oom on i686 with debuginfos
%global debug_package %{nil}
...
...
@@ -733,8 +739,12 @@ echo "ac_add_options --disable-optimize" >> .mozconfig
%endif
%ifarch armv7hl
# ARMv7 need that (rhbz#1426850)
%if %{defined el8}
%global optimize_flags "-g0 -O2 -fno-schedule-insns -fno-lto"
%else
%global optimize_flags "-g -O2 -fno-schedule-insns"
%endif
%endif
%ifarch ppc64le aarch64
%global optimize_flags "-g -O2"
%endif
...
...
@@ -1131,6 +1141,13 @@ MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | %{__sed} -e 's/-g/-g1/')
export MOZ_DEBUG_FLAGS=" "
%endif
%ifarch %{arm}
%if %{defined el8}
MOZ_OPT_FLAGS=$(echo "$MOZ_OPT_FLAGS" | %{__sed} -e 's/-g/-g0/')
export MOZ_DEBUG_FLAGS=" "
%endif
%endif
# We don't wantfirefox to use CK_GCM_PARAMS_V3 in nss
MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -DNSS_PKCS11_3_0_STRICT"
...
...
This diff is collapsed.
Click to expand it.
Write
Preview
Supports
Markdown
0%
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment
Menu
Explore
Projects
Groups
Topics
Snippets