Skip to content
GitLab
Explore
Projects
Groups
Topics
Snippets
Projects
Groups
Topics
Snippets
/
Help
Help
Support
Community forum
Keyboard shortcuts
?
Submit feedback
Register
Sign in
Toggle navigation
Menu
upstream
rpms
firefox
Commits
c277d204
Commit
c277d204
authored
3 years ago
by
CentOS Sources
Browse files
Options
Download
Patches
Plain Diff
import firefox-78.13.0-2.el8_4
parent
2e0f17d8
c8s
imports/c8s/firefox-91.2.0-1.el8_4
imports/c8s/firefox-78.13.0-2.el8_4
No related merge requests found
Changes
6
Hide whitespace changes
Inline
Side-by-side
Showing
6 changed files
.firefox.metadata
+2
-2
.firefox.metadata
.gitignore
+2
-2
.gitignore
SOURCES/Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
+0
-12
.../Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
SOURCES/Bug-1526653---fix_user_vfp_armv7.patch
+0
-35
SOURCES/Bug-1526653---fix_user_vfp_armv7.patch
SOURCES/firefox-centos-default-prefs.js
+0
-35
SOURCES/firefox-centos-default-prefs.js
SPECS/firefox.spec
+19
-6
SPECS/firefox.spec
with
23 additions
and
92 deletions
+23
-92
.firefox.metadata
+
2
−
2
View file @
c277d204
18a8f30a0356c751b8d0ea6f76e764cab13ee046 SOURCES/Python-2.7.13.tar.xz
a9effcc06cf80eaa22f12c1f7d6aa4266a1c4966 SOURCES/cbindgen-vendor-0.14.3.tar.xz
83ae378d8bddd9efc5badb99a6246979313f7134
SOURCES/firefox-78.1
2
.0esr.source.tar.xz
a469453c2e84de2a22dccdb53ab8ca997cddd12
7 SOURCES/firefox-langpacks-78.1
2
.0esr-20210
707
.tar.xz
0da70b30de24716246dd090cf4b3245c91c5931c
SOURCES/firefox-78.1
3
.0esr.source.tar.xz
140765234e3d4340710e09632d9af4a88ea10ba
7 SOURCES/firefox-langpacks-78.1
3
.0esr-20210
805
.tar.xz
0de63f863b158454b9429234b52ed28a397ec45c SOURCES/gtk3-private-3.22.26-1.el6.src.rpm
e188ab1a444697bc649e223c28389d82ca94c472 SOURCES/libffi-3.0.13-18.el7_3.src.rpm
5715f987bc0024ce5d72993cb101b8268350033b SOURCES/nodejs-10.21.0-5.fc32.src.rpm
...
...
This diff is collapsed.
Click to expand it.
.gitignore
+
2
−
2
View file @
c277d204
SOURCES/Python-2.7.13.tar.xz
SOURCES/cbindgen-vendor-0.14.3.tar.xz
SOURCES/firefox-78.1
2
.0esr.source.tar.xz
SOURCES/firefox-langpacks-78.1
2
.0esr-20210
707
.tar.xz
SOURCES/firefox-78.1
3
.0esr.source.tar.xz
SOURCES/firefox-langpacks-78.1
3
.0esr-20210
805
.tar.xz
SOURCES/gtk3-private-3.22.26-1.el6.src.rpm
SOURCES/libffi-3.0.13-18.el7_3.src.rpm
SOURCES/nodejs-10.21.0-5.fc32.src.rpm
...
...
This diff is collapsed.
Click to expand it.
SOURCES/Bug-1238661---fix-mozillaSignalTrampoline-to-work-.patch
deleted
100644 → 0
+
0
−
12
View file @
2e0f17d8
diff -up firefox-60.0/mfbt/LinuxSignal.h.mozilla-1238661 firefox-60.0/mfbt/LinuxSignal.h
--- firefox-60.0/mfbt/LinuxSignal.h.mozilla-1238661 2018-04-27 08:55:38.848241768 +0200
+++ firefox-60.0/mfbt/LinuxSignal.h 2018-04-27 09:06:47.946769859 +0200
@@ -22,7 +22,7 @@
__attribute__((naked)) void SignalTrampo
void* aContext) {
asm volatile("nop; nop; nop; nop" : : : "memory");
- asm volatile("b %0" : : "X"(H) : "memory");
+ asm volatile("bx %0" : : "r"(H), "l"(aSignal), "l"(aInfo), "l"(aContext) : "memory");
}
# define MOZ_SIGNAL_TRAMPOLINE(h) (mozilla::SignalTrampoline<h>)
This diff is collapsed.
Click to expand it.
SOURCES/Bug-1526653---fix_user_vfp_armv7.patch
deleted
100644 → 0
+
0
−
35
View file @
2e0f17d8
From fd6847c9416f9eebde636e21d794d25d1be8791d Mon Sep 17 00:00:00 2001
From: Mike Hommey <mh@glandium.org>
Date: Sat, 1 Jun 2019 09:06:01 +0900
Subject: [PATCH] Bug 1526653 - Include struct definitions for user_vfp and
user_vfp_exc.
---
js/src/wasm/WasmSignalHandlers.cpp | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
diff --git a/js/src/wasm/WasmSignalHandlers.cpp b/js/src/wasm/WasmSignalHandlers.cpp
index 636537f8478..383c380f04c 100644
--- a/js/src/wasm/WasmSignalHandlers.cpp
+++ b/js/src/wasm/WasmSignalHandlers.cpp
@@ -248,7 +248,16 @@
using mozilla::DebugOnly;
#endif
#ifdef WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
-# include <sys/user.h>
+struct user_vfp {
+ unsigned long long fpregs[32];
+ unsigned long fpscr;
+};
+
+struct user_vfp_exc {
+ unsigned long fpexc;
+ unsigned long fpinst;
+ unsigned long fpinst2;
+};
#endif
#if defined(ANDROID)
--
2.20.1
This diff is collapsed.
Click to expand it.
SOURCES/firefox-centos-default-prefs.js
deleted
100644 → 0
+
0
−
35
View file @
2e0f17d8
pref
(
"
app.update.auto
"
,
false
);
pref
(
"
app.update.enabled
"
,
false
);
pref
(
"
app.update.autoInstallEnabled
"
,
false
);
pref
(
"
general.smoothScroll
"
,
true
);
pref
(
"
intl.locale.matchOS
"
,
true
);
pref
(
"
toolkit.storage.synchronous
"
,
0
);
pref
(
"
toolkit.networkmanager.disable
"
,
false
);
pref
(
"
offline.autoDetect
"
,
true
);
pref
(
"
browser.backspace_action
"
,
2
);
pref
(
"
browser.display.use_system_colors
"
,
true
);
pref
(
"
browser.download.folderList
"
,
1
);
pref
(
"
browser.link.open_external
"
,
3
);
pref
(
"
browser.shell.checkDefaultBrowser
"
,
false
);
pref
(
"
network.manage-offline-status
"
,
true
);
pref
(
"
extensions.shownSelectionUI
"
,
true
);
pref
(
"
ui.SpellCheckerUnderlineStyle
"
,
1
);
pref
(
"
startup.homepage_override_url
"
,
"
http://www.centos.org
"
);
pref
(
"
startup.homepage_welcome_url
"
,
"
http://www.centos.org
"
);
pref
(
"
browser.startup.homepage
"
,
"
data:text/plain,browser.startup.homepage=file:///usr/share/doc/HTML/index.html
"
);
pref
(
"
geo.wifi.uri
"
,
"
https://location.services.mozilla.com/v1/geolocate?key=%MOZILLA_API_KEY%
"
);
pref
(
"
media.gmp-gmpopenh264.provider.enabled
"
,
false
);
pref
(
"
media.gmp-gmpopenh264.autoupdate
"
,
false
);
pref
(
"
media.gmp-gmpopenh264.enabled
"
,
false
);
pref
(
"
media.gmp-gmpopenh264.enabled
"
,
false
);
pref
(
"
plugins.notifyMissingFlash
"
,
false
);
/* See https://bugzilla.redhat.com/show_bug.cgi?id=1226489 */
pref
(
"
browser.display.use_system_colors
"
,
false
);
pref
(
"
layers.use-image-offscreen-surfaces
"
,
false
);
/* Allow sending credetials to all https:// sites */
pref
(
"
network.negotiate-auth.trusted-uris
"
,
"
https://
"
);
pref
(
"
security.use_sqldb
"
,
false
);
/* Use OS settings for UI language */
pref
(
"
intl.locale.requested
"
,
""
);
/* See https://bugzilla.redhat.com/show_bug.cgi?id=1672424 */
pref
(
"
storage.nfs_filesystem
"
,
true
);
This diff is collapsed.
Click to expand it.
SPECS/firefox.spec
+
19
−
6
View file @
c277d204
...
...
@@ -16,6 +16,10 @@ function dist_to_rhel_minor(str, start)
if match then
return string.sub(match, 6)
end
match = string.match(str, ".el8")
if match then
return 5
end
return -1
end}
...
...
@@ -124,7 +128,7 @@ end}
# Build as a debug package?
%global debug_build 0
#%global default_bookmarks_file %{_datadir}/bookmarks/default-bookmarks.html
#%
%
global default_bookmarks_file
%
%{_datadir}/bookmarks/default-bookmarks.html
# need to use full path because of flatpak where datadir is /app/share
%global default_bookmarks_file /usr/share/bookmarks/default-bookmarks.html
%global firefox_app_id \{ec8030f7-c20a-464f-9b0e-13a3a9e97384\}
...
...
@@ -139,10 +143,10 @@ end}
%global nspr_version 4.25
# NSS/NSPR quite often ends in build override, so as requirement the version
# we're building against could bring us some broken dependencies from time to time.
#%global nspr_build_version %(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
#%
%
global nspr_build_version
%
%(pkg-config --silence-errors --modversion nspr 2>/dev/null || echo 65536)
%global nspr_build_version %{nspr_version}
%global nss_version 3.53.1
#%global nss_build_version %(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
#%
%
global nss_build_version
%
%(pkg-config --silence-errors --modversion nss 2>/dev/null || echo 65536)
%global nss_build_version %{nss_version}
%endif
...
...
@@ -210,8 +214,8 @@ end}
Summary: Mozilla Firefox Web browser
Name: firefox
Version: 78.1
2
.0
Release:
1
%{?dist}
Version: 78.1
3
.0
Release:
2
%{?dist}
URL: https://www.mozilla.org/firefox/
License: MPLv1.1 or GPLv2+ or LGPLv2+
%if 0%{?rhel} == 7
...
...
@@ -223,7 +227,7 @@ ExclusiveArch: i686 x86_64 ppc64 s390x
Source0: https://hg.mozilla.org/releases/mozilla-release/archive/firefox-%{version}%{?pre_version}.source.tar.xz
%if %{build_langpacks}
Source1: firefox-langpacks-%{version}%{?pre_version}-20210
707
.tar.xz
Source1: firefox-langpacks-%{version}%{?pre_version}-20210
805
.tar.xz
%endif
Source2: cbindgen-vendor-0.14.3.tar.xz
Source10: firefox-mozconfig
...
...
@@ -1685,6 +1689,15 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
#---------------------------------------------------------------------
%changelog
* Thu Aug 05 2021 Eike Rathke <erack@redhat.com> - 78.13.0-2
- Update to 78.13.0 build2
* Tue Aug 03 2021 Eike Rathke <erack@redhat.com> - 78.13.0-1
- Update to 78.13.0 build1
* Fri Jul 16 2021 Jan Horak <jhorak@redhat.com> - 78.12.0-2
- Rebuild to pickup older nss
* Wed Jul 07 2021 Eike Rathke <erack@redhat.com> - 78.12.0-1
- Update to 78.12.0 build1
...
...
This diff is collapsed.
Click to expand it.
Write
Preview
Supports
Markdown
0%
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment
Menu
Explore
Projects
Groups
Topics
Snippets