Skip to content
GitLab
Explore
Projects
Groups
Topics
Snippets
Projects
Groups
Topics
Snippets
/
Help
Help
Support
Community forum
Keyboard shortcuts
?
Submit feedback
Register
Sign in
Toggle navigation
Menu
upstream
rpms
python-jinja2
Commits
05b1f8b8
Commit
05b1f8b8
authored
10 months ago
by
CentOS Sources
Browse files
Options
Download
Patches
Plain Diff
import python-jinja2-2.10-10.module+el8.10.0+21290+abd5b761
parent
8dc7c7e0
c8-stream-2.7
imports/c8-stream-2.7/python-jinja2-2.10-10.module+el8.10.0+21290+abd5b761
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/CVE-2024-22195.patch
+77
-0
SOURCES/CVE-2024-22195.patch
SPECS/python-jinja2.spec
+10
-1
SPECS/python-jinja2.spec
with
87 additions
and
1 deletion
+87
-1
SOURCES/CVE-2024-22195.patch
0 → 100644
+
77
−
0
View file @
05b1f8b8
From 96ac0c552fb0a782a1361dfc65f63c3a134ced03 Mon Sep 17 00:00:00 2001
From: Calum Hutton <calum.hutton@snyk.io>
Date: Thu, 26 Oct 2023 12:08:53 +0100
Subject: [PATCH] xmlattr filter disallows keys with spaces
---
Jinja2-2.10/jinja2/filters.py | 26 +++++++++++++++++++-------
Jinja2-2.10/tests/test_filters.py | 6 ++++++
2 files changed, 25 insertions(+), 7 deletions(-)
diff --git a/Jinja2-2.10/jinja2/filters.py b/Jinja2-2.10/jinja2/filters.py
index 267dddd..b73c3ad 100644
--- a/Jinja2-2.10/jinja2/filters.py
+++ b/Jinja2-2.10/jinja2/filters.py
@@ -150,11 +150,15 @@
def do_lower(s):
return soft_unicode(s).lower()
+_space_re = re.compile(r"\s")
+
+
@evalcontextfilter
def do_xmlattr(_eval_ctx, d, autospace=True):
"""Create an SGML/XML attribute string based on the items in a dict.
- All values that are neither `none` nor `undefined` are automatically
- escaped:
+
+ If any key contains a space, this fails with a ``ValueError``. Values that
+ are neither ``none`` nor ``undefined`` are automatically escaped.
.. sourcecode:: html+jinja
@@ -174,11 +178,19 @@
def do_xmlattr(_eval_ctx, d, autospace=True):
As you can see it automatically prepends a space in front of the item
if the filter returned something unless the second parameter is false.
"""
- rv = u' '.join(
- u'%s="%s"' % (escape(key), escape(value))
- for key, value in iteritems(d)
- if value is not None and not isinstance(value, Undefined)
- )
+ items = []
+
+ for key, value in d.items():
+ if value is None or isinstance(value, Undefined):
+ continue
+
+ if _space_re.search(key) is not None:
+ raise ValueError("Spaces are not allowed in attributes: '{}'".format(key))
+
+ items.append('{}="{}"'.format(escape(key), escape(value)))
+
+ rv = " ".join(items)
+
if autospace and rv:
rv = u' ' + rv
if _eval_ctx.autoescape:
diff --git a/tests/test_filters.py b/tests/test_filters.py
index 8962ced..911d10a 100644
--- a/Jinja2-2.10/tests/test_filters.py
+++ b/Jinja2-2.10/tests/test_filters.py
@@ -389,6 +389,12 @@
class TestFilter(object):
assert 'bar="23"' in out
assert 'blub:blub="<?>"' in out
+ def test_xmlattr_key_with_spaces(self, env):
+ with pytest.raises(ValueError, match="Spaces are not allowed"):
+ env.from_string(
+ "{{ {'src=1 onerror=alert(1)': 'my_class'}|xmlattr }}"
+ ).render()
+
def test_sort1(self, env):
tmpl = env.from_string(
'{{ [2, 3, 1]|sort }}|{{ [2, 3, 1]|sort(true) }}')
--
2.43.0
This diff is collapsed.
Click to expand it.
SPECS/python-jinja2.spec
+
10
−
1
View file @
05b1f8b8
...
...
@@ -21,7 +21,7 @@
Name: python-jinja2
Version: 2.10
Release:
9
%{?dist}
Release:
10
%{?dist}
Summary: General purpose template engine
Group: Development/Languages
License: BSD
...
...
@@ -34,6 +34,10 @@ Source0: https://files.pythonhosted.org/packages/source/J/Jinja2/Jinja2-%
# Tracking bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1928707
Patch0: CVE-2020-28493.patch
# Security fix for CVE-2024-22195
# Resolved upstream: https://github.com/pallets/jinja/commit/7dd3680e6eea0d77fde024763657aa4d884ddb23
Patch1: CVE-2024-22195.patch
BuildArch: noarch
%description
...
...
@@ -110,6 +114,7 @@ environments.
%setup -qc -n Jinja2-%{version}
%patch0 -p1
%patch1 -p1
# cleanup
find Jinja2-%{version} -name '*.pyo' -o -name '*.pyc' -delete
...
...
@@ -210,6 +215,10 @@ popd
%changelog
* Tue Jan 30 2024 Charalampos Stratakis <cstratak@redhat.com> - 2.10-10
- Security fix for CVE-2024-22195
Resolves: RHEL-21348
* Fri Mar 12 2021 Lumír Balhar <lbalhar@redhat.com> - 2.10-9
- Fix CVE-2020-28493: ReDOS vulnerability due to the sub-pattern
Resolves: rhbz#1928707
...
...
This diff is collapsed.
Click to expand it.
Write
Preview
Supports
Markdown
0%
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment
Menu
Explore
Projects
Groups
Topics
Snippets