Skip to content
GitLab
Explore
Projects
Groups
Topics
Snippets
Projects
Groups
Topics
Snippets
/
Help
Help
Support
Community forum
Keyboard shortcuts
?
Submit feedback
Register
Sign in
Toggle navigation
Menu
upstream
rpms
python-jinja2
Commits
91f1252e
Commit
91f1252e
authored
5 months ago
by
CentOS Sources
Browse files
Options
Download
Patches
Plain Diff
import python-jinja2-2.11.3-5.el9
parent
7c12ae90
c9
imports/c9/python-jinja2-2.11.3-8.el9_5
imports/c9/python-jinja2-2.11.3-7.el9_5
imports/c9/python-jinja2-2.11.3-6.el9
imports/c9/python-jinja2-2.11.3-5.el9
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
SOURCES/0003-CVE-2024-22195.patch
+77
-0
SOURCES/0003-CVE-2024-22195.patch
SPECS/python-jinja2.spec
+9
-1
SPECS/python-jinja2.spec
with
86 additions
and
1 deletion
+86
-1
SOURCES/0003-CVE-2024-22195.patch
0 → 100644
+
77
−
0
View file @
91f1252e
From d9835bd39a630ea74f719e1c76765ca2ec89f2f2 Mon Sep 17 00:00:00 2001
From: Calum Hutton <calum.hutton@snyk.io>
Date: Thu, 26 Oct 2023 12:08:53 +0100
Subject: [PATCH] xmlattr filter disallows keys with spaces
---
src/jinja2/filters.py | 26 +++++++++++++++++++-------
tests/test_filters.py | 6 ++++++
2 files changed, 25 insertions(+), 7 deletions(-)
diff --git a/src/jinja2/filters.py b/src/jinja2/filters.py
index 74b108d..49f7d39 100644
--- a/src/jinja2/filters.py
+++ b/src/jinja2/filters.py
@@ -205,11 +205,15 @@
def do_lower(s):
return soft_unicode(s).lower()
+_space_re = re.compile(r"\s", flags=re.ASCII)
+
+
@evalcontextfilter
def do_xmlattr(_eval_ctx, d, autospace=True):
"""Create an SGML/XML attribute string based on the items in a dict.
- All values that are neither `none` nor `undefined` are automatically
- escaped:
+
+ If any key contains a space, this fails with a ``ValueError``. Values that
+ are neither ``none`` nor ``undefined`` are automatically escaped.
.. sourcecode:: html+jinja
@@ -229,11 +233,19 @@
def do_xmlattr(_eval_ctx, d, autospace=True):
As you can see it automatically prepends a space in front of the item
if the filter returned something unless the second parameter is false.
"""
- rv = u" ".join(
- u'%s="%s"' % (escape(key), escape(value))
- for key, value in iteritems(d)
- if value is not None and not isinstance(value, Undefined)
- )
+ items = []
+
+ for key, value in d.items():
+ if value is None or isinstance(value, Undefined):
+ continue
+
+ if _space_re.search(key) is not None:
+ raise ValueError(f"Spaces are not allowed in attributes: '{key}'")
+
+ items.append(f'{escape(key)}="{escape(value)}"')
+
+ rv = " ".join(items)
+
if autospace and rv:
rv = u" " + rv
if _eval_ctx.autoescape:
diff --git a/tests/test_filters.py b/tests/test_filters.py
index 388c346..6e697f3 100644
--- a/tests/test_filters.py
+++ b/tests/test_filters.py
@@ -440,6 +440,12 @@
class TestFilter(object):
assert 'bar="23"' in out
assert 'blub:blub="<?>"' in out
+ def test_xmlattr_key_with_spaces(self, env):
+ with pytest.raises(ValueError, match="Spaces are not allowed"):
+ env.from_string(
+ "{{ {'src=1 onerror=alert(1)': 'my_class'}|xmlattr }}"
+ ).render()
+
def test_sort1(self, env):
tmpl = env.from_string("{{ [2, 3, 1]|sort }}|{{ [2, 3, 1]|sort(true) }}")
assert tmpl.render() == "[1, 2, 3]|[3, 2, 1]"
--
2.43.0
This diff is collapsed.
Click to expand it.
SPECS/python-jinja2.spec
+
9
−
1
View file @
91f1252e
...
...
@@ -2,7 +2,7 @@
Name: python-jinja2
Version: 2.11.3
Release:
4
%{?dist}
Release:
5
%{?dist}
Summary: General purpose template engine
License: BSD
URL: https://palletsprojects.com/p/jinja/
...
...
@@ -11,6 +11,10 @@ Source0: %{pypi_source}
Patch1: 0001-add-linetable-to-the-preserved-CodeType-attributes-1.patch
Patch2: 0002-native_concat-pass-only-strings-to-literal_eval.patch
# Security fix for CVE-2024-22195
# Resolved upstream: https://github.com/pallets/jinja/commit/7dd3680e6eea0d77fde024763657aa4d884ddb23
Patch3: 0003-CVE-2024-22195.patch
%if 0%{?fedora} || 0%{?rhel} > 7
# Enable python3 build by default
%bcond_without python3
...
...
@@ -182,6 +186,10 @@ PYTHONPATH=$(pwd)/src %{__python3} -m pytest tests
%changelog
* Tue Jan 30 2024 Charalampos Stratakis <cstratak@redhat.com> - 2.11.3-5
- Security fix for CVE-2024-22195
Resolves: RHEL-21349
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 2.11.3-4
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
...
...
This diff is collapsed.
Click to expand it.
Write
Preview
Supports
Markdown
0%
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment
Menu
Explore
Projects
Groups
Topics
Snippets